Bug #192

nomacs on linux do not show exif metadata

Added by Anonymous over 6 years ago. Updated about 5 years ago.

Status:ClosedStart date:07.03.2013
Priority:NormalDue date:
Assignee:Stefan% Done:

100%

Category:-
Target version:2.0
Version:1.0.0 Operating System:

Description

nomacs on linux do not show exif metadata,

jhead 20120420-175826.jpg

File name : 20120420-175826.jpg
File size : 233108 bytes
File date : 2012:04:24 07:54:09
Camera make : SONY
Camera model : SLT-A35
Date/Time : 2012:04:20 17:58:26
Resolution : 1600 x 1077
Flash used : No
Focal length : 35.0mm (35mm equivalent: 52mm)
Exposure time: 0.0050 s (1/200)
Aperture : f/4.5
ISO equiv. : 400
Exposure bias: 0.30
Whitebalance : Auto
Metering Mode: pattern
Exposure : shutter priority (semi-auto)

nomacs.png - metadata info (312 KB) Preview Anonymous, 07.03.2013 15:31

screenshot-metadata.png - linux screenshot with metadata (787 KB) Preview Stefan, 07.03.2013 15:55

20120420-175826.jpg - source image (228 KB) Preview Radoslav, 08.03.2013 07:09

eog.png - metadata info in Eye og Gnome (770 KB) Preview Radoslav, 08.03.2013 07:16

nomacs_1.0.0-1_i386.deb - nomacs 1.0.0 with debug output (998 KB) Stefan, 12.03.2013 12:21

nomacs_debug_single_image_in_folder.png - metadata ok, single file in folder, screenshot (372 KB) Preview Radoslav, 12.03.2013 16:01

nomacs_debug_single_image_in_folder.log Magnifier - metadata ok, single file in folder, debug log (2.72 KB) Radoslav, 12.03.2013 16:01

nomacs_debug_multiple_images_in_folder.png - missing metadata, multiple images in folder, screenshot (316 KB) Preview Radoslav, 12.03.2013 16:01

nomacs_debug_multiple_images_in_folder.log Magnifier - missing metadata, multiple images in folder, debug log (15.3 KB) Radoslav, 12.03.2013 16:01

nomacs_arw.log Magnifier - raw image, debug log (1.27 KB) Radoslav, 12.03.2013 16:50

nomacs_arw.png - raw image, screenshot (67.1 KB) Preview Radoslav, 12.03.2013 16:50

26
27
28
29
32
34
37

Related issues

Duplicated by Bug #206: EXIF data not detected in UTF-8 directories Closed 31.03.2013

History

#1 Updated by Florian over 6 years ago

  • Assignee set to Stefan

#2 Updated by Stefan over 6 years ago

hi,

just testet it with xubuntu 12.04 and debian testing and the metadata is shown (see attached screenshot). Which Linux are you using and can you provide us your jpg?

Thanks

Stefan

#3 Updated by Radoslav over 6 years ago

source image ,
jhead info is in first post

#4 Updated by Radoslav over 6 years ago

metadata info in Eye og Gnome is correct.
I'm using Ubuntu 12.0.4

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS"

installed exif libraries:
dpkg -l exif
@Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Description
+++-===========================================-===========================================-======================================================================================================
ii libexif12 0.6.20-2ubuntu0.1 library to parse EXIF files
@

installed nomacs package:
dpkg -l nomacs
@Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Description
+++-===========================================-===========================================-======================================================================================================
ii nomacs 1.0.0-1~8~precise1 image viewer with capability of syncing multiple instances
@

#5 Updated by Stefan over 6 years ago

strange

i installed ubuntu 12.04 and everything works for me. The metadata is displayed. Are you using 32 or 64 bit?

and nomacs does not use the libexif12 package, it uses this one:
ii libexiv2-11 0.22-2 EXIF/IPTC metadata manipulation library

Greetings

#6 Updated by Radoslav over 6 years ago

I'm using Ubuntu 32bit.
Today I installed nomacs on OS X 10.8.2 with MacPorts (nomacs @1.0.0_1 (active)) and it is affected with same bug.

So how can I help you with debugging ?

#7 Updated by Radoslav over 6 years ago

installed exiv2 packages on Ubuntu 12.4.2 32bit

ii libexiv2-11 0.22-2 EXIF/IPTC metadata manipulation library
ii libexiv2-12 0.23-1pmjdebruijn8~precise EXIF/IPTC metadata manipulation library
ii libexiv2-dev 0.23-1pmjdebruijn8~precise EXIF/IPTC metadata manipulation library - development files

I have installed Darktable too, so I purged libexiv2-12 , and then tried nomacs again with only libexiv2-11.
Still I can't see metadata info

#8 Updated by Stefan over 6 years ago

hi,

this is really a strange problem and we are not sure were a problem can occur. Attached is a ubuntu 32bit nomacs package with the debug output enabled. Can you please install this package. Then start nomacs from the console and load your image. Afterwards please send us the debug output. Perhaps this helps to limit the possibilities where the problem occurs.

Greetings

#9 Updated by Radoslav over 6 years ago

Ok, now I found where is problem
when I open only 1 image in folder, then metadata are read,
but when I open image in folder, where are multiple images, and some do not have metadata, then metadata are not read

attaching screenshots and logs

#10 Updated by Radoslav over 6 years ago

Maybe I was wrong,
Problem is in unicode characters "ľščťžýáíé" in path and filenames

#11 Updated by Markus over 6 years ago

thank you! now we can reproduce the bug -> it is that the metadata library cannot handle unicode filenames... we try to fix this and give you response as soon as there is a solution.

#12 Updated by Radoslav over 6 years ago

Same problem is with loading RAW images (.arw from Sony).
When path or file name contains Unicode char. it isn't loaded.

#13 Updated by Markus over 6 years ago

  • Target version set to 1.2.0

the problem here is, that exiv2 does not support unicode file strings on operating systems other than windows. we have found a workaround. however, this will take at least until version 1.2 of nomacs to implement this since major redesigns are needed...

#14 Updated by Radek over 6 years ago

This is not limited to non-Windows OSs at all (as reported in duplicate).

#15 Updated by Markus over 6 years ago

  • % Done changed from 0 to 30

for the 1.0.1 version, this bug is fixed for windows systems...

#16 Updated by Stefan about 6 years ago

  • Target version changed from 1.2.0 to 1.6.0

#17 Updated by Stefan almost 6 years ago

  • Target version changed from 1.6.0 to 1.8.0

#18 Updated by Markus over 5 years ago

  • Target version changed from 1.8.0 to 2.0
  • % Done changed from 30 to 100

finally we get this done

#19 Updated by Markus about 5 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF