Support #300

update the osx build

Added by Anonymous over 5 years ago. Updated over 3 years ago.

Status:NewStart date:02.02.2014
Priority:NormalDue date:
Assignee:petr% Done:

0%

Category:-
Target version:-
Version: Operating System:

Description

The latest version of nomacs is 1.6.2, but the only available download for Mac OS X is only 1.0.0, which is almost a year old.

History

#1 Updated by Markus over 5 years ago

you can find the updated (1.6.2) version here:
http://www.macports.org/ports.php?by=name&substr=nomacs
is that not what you need?

#2 Updated by Markus over 5 years ago

hi again,

could you please test this bundle since we need to know if all dependencies are included before releasing...
http://public.yarpen.cz/nomacs-1.6.2.tar.bz2

#3 Updated by miso over 5 years ago

Markus wrote:

you can find the updated (1.6.2) version here:
http://www.macports.org/ports.php?by=name&substr=nomacs
is that not what you need?

Macports is a bit too advanced for many mac users.

#4 Updated by miso over 5 years ago

Markus wrote:

hi again,

could you please test this bundle since we need to know if all dependencies are included before releasing...
http://public.yarpen.cz/nomacs-1.6.2.tar.bz2

Tested it and it appears to work ok.

#5 Updated by miso over 5 years ago

miso wrote:

Markus wrote:

hi again,

could you please test this bundle since we need to know if all dependencies are included before releasing...
http://public.yarpen.cz/nomacs-1.6.2.tar.bz2

Tested it and it appears to work ok.

BTW, there's now a page for nomacs on macupdate: https://www.macupdate.com/app/mac/50335/nomacs

#6 Updated by Markus over 5 years ago

thanks a lot,
we will add this link to the download page

EDIT: I just noticed, that the download on macupdate is still 1.0.0, is there a way for us (or for you) to update this version?

#7 Updated by miso over 5 years ago

Markus wrote:

thanks a lot,
we will add this link to the download page

macupdate doesn't mirror your dmg, they only redirect to your site, probably to count downloads. so including the link on the download page is useless. i was just letting you know that the app will now get some wider exposure.

EDIT: I just noticed, that the download on macupdate is still 1.0.0, is there a way for us (or for you) to update this version?

the macupdate editors probably looked on the download page and saw you only had a link to the 1.0 dmg. if you want to keep that page up to date, there's a link at the bottom of the page pointing here: https://www.macupdate.com/developers/update/

#8 Updated by petr over 5 years ago

  • Assignee set to petr

hi all,
I just updated macports package to 1.6.4.

ad standalone package - do you want to have 1.6.4 as it was for http://public.yarpen.cz/nomacs-1.6.2.tar.bz2 ? I'm afraid (due nature of OS X) it can fail on any other OS X version than Maverick (10.9.x) but I can create a dmg (can this stupid OS X stop correct this word to "dog"?) easily...

#9 Updated by miso almost 5 years ago

So the available Mac version keeps falling further behind other platforms. The latest official DMG bundle is still only 1.0.0 and the latest MacPorts version is only 1.6.4.

#10 Updated by petr almost 5 years ago

guys, you have to ping me on new release. Or some days before the release would be better - to fix the potential compilation issues...

#11 Updated by petr almost 5 years ago

macports has been updated to 2.0.2 (it went really smoothly).

BTW how is it with Qt5 support, please? Qt5 makes creation of distributable application bundles quite easier on OS X...

#12 Updated by Stefan almost 5 years ago

hi.
sorry, the next time we will ping you ...

i just fixed the cmake and compile errors for Qt5 (in master and developer), so on Linux it worked and i tried to bring all the changes to the mac cmake file. So Qt5 should now work

#13 Updated by miso over 4 years ago

Stefan wrote:

hi.
sorry, the next time we will ping you ...

i just fixed the cmake and compile errors for Qt5 (in master and developer), so on Linux it worked and i tried to bring all the changes to the mac cmake file. So Qt5 should now work

so now there's no mac version? using macports is not an option for grammas and the like. you need an app file distributed in a dmg, so they can just drag it into their Applications folder.

#14 Updated by Stefan over 4 years ago

apprently only a outdated. Since we do not own any mac computer we are unable to build the package on ourselves

#15 Updated by miso over 4 years ago

Stefan wrote:

apprently only a outdated.

The link to the outdated app is no longer on the download page, only the macport link. Plus, it implies it doesn't work on Mavericks (the latest os version) because the download page only mentions the previous os versions.

Since we do not own any mac computer we are unable to build the package on ourselves

That's the beauty of open source, there's plenty of people out there who can easily do it. It's just a matter a getting their attention. Maybe a notice on the front page, or posting on reddit or elsewhere.

#16 Updated by Martin over 3 years ago

Created two PRs of which one is focusing on the documentation incl. how to build for OSX and another one for setting up builds (Linux and OSX for now) on Travis CI infrastructure.

https://github.com/nomacs/nomacs/pull/37
https://github.com/nomacs/nomacs/pull/38

From Travis we could also deploy the artifacts to either Bintray or Github releases and from there on to homebrew, etc.

Also available in: Atom PDF