Bug #423

Nomacs 2.4.2 Batch Tools dialogue does not display fully after batch process under XFCE 4.12

Added by Prodigal over 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:03.03.2015
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:3.0
Version:2.4.2 Operating System:Linux 64bit

Description

Nomacs 2.4.2 Batch Tools dialogue does not display fully after batch process under XFCE 4.12 in that once invoked and task is completed, the CLOSE button and so on is not visible. Hitting the ENTER key brings up a strange dialogue with the CLOSE button in it etc.. Also note the crash after closing.

See attached screencast.

NomacsBatchTool_Size_Problem&Crash.mkv (3.14 MB) Prodigal, 03.03.2015 23:58

History

#1 Updated by Prodigal over 4 years ago

Update:

I have reverted back to XFCE 4.10 due to all the QT issues of 4.12. However, the Batch Tools crash problem still exists, but is not as prevelant. Under XFCE 4.10 it is crashing about 40-50% of the time.

The dialogue sizing issue also still exists and seems to coincide with the crashing. If the dialogue does not go screwy, then the crash tends not to happen. However, this is not a hard rule.

#2 Updated by Markus about 4 years ago

  • Target version set to 3.0
  • % Done changed from 0 to 50

the crash seems to be fixed with updating to qt5 (I cannot reproduce it on the current developer branch) but we'll test it on linux too

#3 Updated by Markus almost 4 years ago

  • % Done changed from 50 to 100

I have added a QSplitter which should also fix the size issues

#4 Updated by Markus over 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF