Support #569

Installer not starting

Added by Иван over 3 years ago. Updated over 3 years ago.

Status:NewStart date:17.12.2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Version:3.0 Operating System:Windows 7/8/10 64bit

Description

The installer of 3.0 is not starting, I'm using Windows 7 64 bit. The portable version works. What can I do to provide you some information?
Also I had 2.4.6 installed, it said there was an update, it downloaded it and then nothing happened.

History

#1 Updated by Markus over 3 years ago

Did you try uninstalling nomacs 2.4 and installing nomacs 3 from http://download.nomacs.org?

#2 Updated by Иван over 3 years ago

Yes, I have uninstalled 2.4 and downloaded it. It just doesn't start.

#3 Updated by Markus over 3 years ago

Ah ok... I will test it in the VM tomorrow and write back. Do you have a 64 bit system?

#4 Updated by Иван over 3 years ago

Yes.

#5 Updated by Markus over 3 years ago

Btw if you call the installer from the command line with this argument:
nomacs-setup.exe -v
We would know more...

#6 Updated by Иван over 3 years ago

IFW Version: "2.0.1"
Build date: "Jun 1 2015"
Installer Framework SHA1: "4d8d527"
Auto configuration failed
2656:error:02001015:system library:fopen:Is a directory:.\crypto\bio\bss_file.c:126:fopen('f:/repo_o
penssl-0.9.8za_install/openssl.cnf','rb')
2656:error:2006D002:BIO routines:BIO_new_file:system lib:.\crypto\bio\bss_file.c:131:
2656:error:0E078002:configuration file routines:DEF_LOAD:system lib:.\crypto\conf\conf_def.c:199:

#7 Updated by Markus over 3 years ago

well that's bad - I tested it today in my VM (Win7 64-bit) and the installer starts with this:

IFW Version: "2.0.1"
Build date: "Jun 1 2015"
Installer Framework SHA1: "4d8d527"
[0] Language: en-US
[0] Arguments: nomacs-setup.exe, -v
[741] Operations sanity check succeeded.

since your error seems to be related to an OpenSSL package: do you have OpenSSL installed (or software that uses it such as Cygwin)?

#8 Updated by Иван over 3 years ago

I don't know. How can I check if I have software that uses OpenSSL? I don't have Cygwin.

Also available in: Atom PDF