Bug #723

Big (80 megabytes) PNG images are taking forever to load

Added by Anonymous about 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:02.08.2016
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:3.6
Version:3.4.0.606 Operating System:Windows Vista/7/8 64bit

Description

How to reproduce:
1) Run GIMP
2) Create a 6000x8000 image
3) Generate RGB noise
4) Export as noise.png
5) Open noise.png in nomacs

Expected result:
  • Image opens in less than 1 second
Actual result:
  • Image takes 38 seconds to open

History

#1 Updated by Markus about 3 years ago

  • Status changed from New to Accepted

I did what you said, but I used Photoshop instead of Gimp to generate the image. The resulting file is 88MB (I saved it with and without interlacing), and nomacs pretty much does what you expect:

[INFO] "C:/temp/test-b.png" loaded in 1 sec

could you possibly upload your file -> maybe Gimp does something different...

#2 Updated by L about 3 years ago

I doubt that. This is not just on this particular kind of file (random RGBA noise). Any large PNG file (any color scan made on 600 DPI) causes this.

Actually, after trying it on a few more images, i can't reproduce this anymore. Now everything loads in one second. Weird.

#3 Updated by Markus about 3 years ago

  • % Done changed from 0 to 100

#4 Updated by Markus over 2 years ago

  • Target version set to 3.6

#5 Updated by Markus over 2 years ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF